您的位置:首页 > 其它

Frogger

2015-12-05 23:33 316 查看

Frogger


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the
frog distance between Freddy's and Fiona's stone.

输入

The input file will contain one or more test cases. The first line of each test case will contain the number of stones
n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone,
the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for
n.

输出

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance =
y" where x is replaced by the test case number (they are numbered from 1) and
y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

示例输入

2
0 0
3 4

3
17 4
19 4
18 5

0


示例输出

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


提示

来源

示例程序

#include <iostream>
#include <cmath>
#include<stdio.h>
using namespace std;
double map[210][210];
int n;
struct Stone
{
int x, y;
}s[210];
void Floyd()
{
int i,j,k;
for(k=0; k<n; k++)
for(i=0; i<n-1; i++)
for(j=i+1; j<n; j++)
{
if(map[i][j]>map[i][k] && map[i][j]>map[k][j])
{
if(map[i][k]>map[k][j])
map[j][i]=map[i][j] = map[i][k];
else
map[j][i]=map[i][j] = map[k][j];
}
}
}
double getdis(int a, int b)
{
return sqrt((double)(s[a].x-s[b].x)*(s[a].x-s[b].x)+(double)(s[a].y-s[b].y)*(s[a].y-s[b].y));
}
int main()
{
int Case=0,i,j;
while(scanf("%d", &n), n)
{
for(i=0; i<n; i++)
scanf("%d %d", &s[i].x, &s[i].y);
for(i=0; i<n; i++)
for(j=i+1; j<n; j++)
{
map[i][j]=map[j][i]=getdis(i,j);
}
Floyd();
printf("Scenario #%d\nFrog Distance = %.3lf\n\n", ++Case, map[0][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: