您的位置:首页 > 其它

HDU1078 FatMouse and Cheese记忆化搜索

2015-12-02 20:39 483 查看

FatMouse and Cheese

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.

The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1

1 2 5

10 11 6

12 12 7

-1 -1

Sample Output

37

题解:

简单的记忆化搜索,好久没写搜索,磕磕碰碰总算写好了…

代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int n,k;
int map[105][105];
int dp[105][105];
int dir_x[4] = {0,0,1,-1};
int dir_y[4] = {1,-1,0,0};
int dfs(int x,int y)
{
int ans=0,maxn=0;
if (!dp[x][y])
{
for (int i = 1;i<=k;i++)
{
for (int j = 0;j<4;j++)
{
int dx = x+dir_x[j]*i;
int dy = y+dir_y[j]*i;
if (dx >=0 && dx <n && dy>=0 && dy <n && map[x][y] < map[dx][dy])
{
ans = dfs(dx,dy);
if (ans > maxn)
maxn = ans;
}
}
dp[x][y] = maxn +map[x][y];
}
}
return dp[x][y];
}
int main()
{
while (scanf("%d%d",&n,&k))
{
if (n== -1 && k == -1)
break;
memset(dp,0,sizeof(dp));
memset(map,0,sizeof(map));
for (int i = 0;i<n;i++)
for (int j = 0;j<n;j++)
scanf("%d",&map[i][j]);
int sum = dfs(0,0);
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: