您的位置:首页 > 其它

1032. Sharing (25)

2015-12-01 16:52 267 查看
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.



Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total
number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1

------------------华丽的分割线-----------------------
分析:设立相应的标志数组来存取结果。
代码:
#include<cstdio>
#include<cstdlib>

#define Maxn 100001

typedef struct
{
int address;
char key;
int next;
}Node;

Node input[Maxn];

char test[Maxn];

int main(void)
{
int N,address1,address2;
scanf("%5d %5d %d",&address1,&address2,&N);

int i;
int inaddr,innext;
char inkey;
for(i=0;i<N;++i)
{
scanf("%5d %c %d",&inaddr,&inkey,&innext);
input[inaddr].address = inaddr;
input[inaddr].key = inkey;
input[inaddr].next = innext;
}

int header1 = address1;
while(header1 != -1)
{
test[header1] = input[header1].key;
header1 = input[header1].next;
}

bool havecommon = false;

int header2 = address2;
while(header2 != -1)
{
if(input[header2].key == test[header2])
{
havecommon = true;
break;
}
header2 = input[header2].next;
}

if(havecommon)
{
printf("%05d",header2);
}
else
{
printf("-1");
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: