您的位置:首页 > 其它

题解: HDU 1548 :A strange lift(BFS)

2015-11-29 03:36 405 查看

题目

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?

Input

The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.

A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.

Sample Input

5 1 5

3 3 1 2 5

0

Sample Output

3

翻译

一栋楼有N层 开始在A层 终点在B层

然后第i层的电梯只能下降 ki层 或者上升ki层

问是否能到达

分析

注意 如果下降之后的高度小于1 那么这步操作是不存在的

如果上升之后的高度大于最大值 这一步上升也是作废的

还有一点就是标记的问题

最初想的是标记电梯的按键 即不能进行同一步操作

后来发现 因为是广搜 所以在当前层时所有的按键都将被遍历一次 所以应该标记的是走过的层数

上代码 + 注释

#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <queue>
using namespace std;

int N, A, B;
int a[205];
bool map[205], flag;

struct node
{
int x, step;
}n1, n2, m;

int main()
{
int i;
while (scanf("%d", &N) && N)
{
scanf("%d %d", &A, &B);
for (i = 1; i <= N; i++)
{
scanf("%d", &a[i]);
map[i] = false;
}
flag = false;
n1.x = A; n1.step = 0;
queue<node> Q;
Q.push(n1);
map[n1.x] = true;
while (!Q.empty())
{
m = Q.front();
Q.pop();
if (m.x == B)    //到达目标
{
flag = true;
break;
}
n1.x = m.x - a[m.x];
n2.x = m.x + a[m.x];
if (n1.x>0 && n1.x <= B && !map[n1.x]) //下去的//注意下面标记的都是当前楼层而不是电梯的操作
{
n1.step = m.step + 1;
map[n1.x] = true;   //标记
Q.push(n1);
}
if (n2.x>0 && n2.x <= B && !map[n2.x]) //上去的
{
n2.step = m.step + 1;
map[n2.x] = true;   //标记
Q.push(n2);
}
}
if (flag) printf("%d\n", m.step);
else printf("-1\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: