您的位置:首页 > 其它

1074. Reversing Linked List (25)

2015-11-27 18:25 369 查看


1074. Reversing Linked List (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist
to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1


提交代

http://www.patest.cn/contests/pat-a-practise/1074

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <set>
#include <string>
#include <queue>

using namespace std;

#define N 100005
#define INF 1 << 30

struct node
{
int addr ;
int data ;
int next  ;
};

node vn
;

int main()
{
//freopen("in.txt" , "r" , stdin) ;
int firstAdd , n  , K ;
scanf("%d%d%d",&firstAdd , &n , &K ) ;
int i ;
int Address , Data , Next ;
node nt ;
for(i = 0 ;i < n ; i++)
{
scanf("%d%d%d" , &Address , &Data , &Next) ;
nt.addr = Address ;
nt.data = Data ;
nt.next = Next ;
vn[Address] = nt ;
}
vector<node> vv ;
while(firstAdd != -1)
{
vv.push_back(vn[firstAdd]) ;
firstAdd = vn[firstAdd].next ;
}
int len = vv.size() ;
int count =  len / K ;
vector<node> ans ;
for(i = 0 ; i < count ; i++)
{
int last = (i+1)*K - 1 ;
int first = i * K ;
for(int j = last ; j >= first; j --)
{
ans.push_back(vv[j]) ;
}
}
for(i = count*K ; i < len ; i++)
{
ans.push_back(vv[i]) ;
}

printf("%05d %d " , ans[0].addr , ans[0].data ) ;
for(i = 1 ;i < len ; i++)
{
printf("%05d\n%05d %d " , ans[i].addr , ans[i].addr , ans[i].data) ;
}
printf("-1\n") ;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: