您的位置:首页 > 其它

HDU 1071 The area(计算几何)

2015-11-25 09:32 387 查看
The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8920 Accepted Submission(s): 6272

Problem Description

Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the
area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output

For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input

2

5.000000 5.000000

0.000000 0.000000

10.000000 0.000000

10.000000 10.000000

1.000000 1.000000

14.000000 8.222222

Sample Output

33.33

40.69

Hint

For float may be not accurate enough, please use double instead of float.

Author

Ignatius.L

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int T;
double x1,x2,x3,y1,y2,y3,a,b,c,k,t,x,s1,s2;
cin>>T;
while(T--)
{
cin>>x1>>y1>>x2>>y2>>x3>>y3;
a=(y2-y1)/((x1-x2)*(x1-x2));
b=-2*a*x1;
c=y1+a*x1*x1;
k=(y3-y2)/(x3-x2);
t=y3-(k*x3);
s1=a/3*x3*x3*x3+(b-k)/2*x3*x3+(c-t)*x3;
s2=a/3*x2*x2*x2+(b-k)/2*x2*x2+(c-t)*x2;
printf("%.2lf\n",s1-s2);
}
return 0;
}
/*
设直线方程:y=kx+t…………………………………………………………(1)
抛物线方程:y=ax^2+bx+c……………………………………………………(2)
已知抛物线顶点p1(x1,y1),两线交点p2(x2,y2)和p3(x3,y3)
斜率k=(y3-y2)/(x3-x2)……………………………………………………(3)
把p3点代入(1)式结合(3)式可得:t=y3-(k*x3)
又因为p1是抛物线的顶点,可得关系:x1=-b/2a即b=-2a*x1………………(4)
把p1点代入(2)式结合(4)式可得:a*x1*x1-2a*x1*x1+c=y1化简得c=y1+a*x1*x1……(5)
把p2点代入(2)式结合(4)式和(5)式可得:a=(y2-y1)/((x1-x2)*(x1-x2))
于是通过3点求出了k,t,a,b,c即两个方程式已求出
题目时求面积s
通过积分可知:s=f(x2->x3)(积分符号)(ax^2+bx+c-(kx+t))
=f(x2->x3)(积分符号)(ax^2+(b-k)x+c-t)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: