您的位置:首页 > 其它

【poj2575】Jolly Jumpers

2015-11-22 16:37 393 查看

【poj2575】Jolly Jumpers

Description

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance, 

1 4 2 3 

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly
jumper.
Input

Each line of input contains an integer n < 3000 followed by n integers representing the sequence.
Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly". 

Sample Input
4 1 4 2 3
5 1 4 2 -1 6

Sample Output
Jolly
Not jolly

Source

Waterloo local 2000.09.30
【代码】

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int n,m;
bool pd;
int a[5000];
bool b[5000];
int main(){
while (~scanf("%d",&n)){
for (int i=1;i<=n;++i)
scanf("%d",&a[i]);
memset(b,0,sizeof(b));
for (int i=2;i<=n;++i){
m=abs(a[i]-a[i-1]);
b[m]=true;
}
pd=true;
for (int i=1;i<n;++i)
if (!b[i]){
pd=false;
break;
}
if (pd) printf("Jolly\n");
else printf("Not jolly\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: