您的位置:首页 > 其它

nyoj--233--Sort it (水题)

2015-11-18 21:02 288 查看

Sort it

时间限制:1000 ms | 内存限制:65535 KB

难度:2
描述 You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.

For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.输出For each case, output the minimum times need to sort it in ascending order on a single line.样例输入
3
1 2 3
4
4 3 2 1

样例输出
0
6

来源ZJFC 2009-3 Programming Contest上传者
张洁烽

好久以前没做出来的题,清理一下,的确是有点水

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAX 100100
int num[MAX];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
int sum=0;
int t;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
if(num[i]>num[j])
{
t=num[i],num[i]=num[j],num[j]=t;
sum++;
}
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: