您的位置:首页 > 其它

hdu 1754 I Hate It ----->线段树(区间最值,单点更新)

2015-11-17 17:10 483 查看


I Hate It

Input

本题目包含多组测试,请处理到文件结束。

在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。

学生ID编号分别从1编到N。

第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。

接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。

当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。

当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。


Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5 


Sample Output

5
6
5
9

HintHuge input,the C function scanf() will work better than cin


code:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<string>
#include<stack>
#include<queue>
#include<map>
#define Max(a, b) (a)>(b)?(a):(b)
#define inf 0x3f3f3f3f
#define lson l,m,rt<<1 //找到左儿子
#define rson m+1,r,rt<<1|1//找到右儿子
#define M 200008
#define LL long long
using namespace std;
LL MAX[M<<2];
inline void pushrt(int rt)
{
MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
}
void build(int l,int r,int rt)
{
if(l==r)
{
scanf("%I64d",&MAX[rt]);
return ;
}
int m=(l+r)>>1;
build(lson);
build(rson);
pushrt(rt);
}
void update(int p,int q,int l,int r,int rt)
{
if(l==r)
{
MAX[rt]=q;
return ;
}
int m=(l+r)>>1;
if(p<=m)
update(p,q,lson);
else
update(p,q,rson);
pushrt(rt);
}
LL query(int p,int q,int l,int r,int rt)
{
if(p<=l&&r<=q)
return MAX[rt];
int m=(r+l)>>1;
LL ret=0;
//选出最大值
if(p<=m)
ret = max(ret,query(p,q,lson));
if(q>m)
ret = max(ret,query(p,q,rson));

return ret;
}
int main()
{
int n,m,p,q;
char op;
while(~scanf("%d%d",&n,&m))
{
build(1,n,1);
while(m--)
{
getchar(); //注意
scanf("%c%d%d",&op,&p,&q);
if(op=='Q')
printf("%I64d\n",query(p,q,1,n,1));
else
update(p,q,1,n,1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: