您的位置:首页 > 产品设计 > UI/UE

Number Sequence

2015-11-13 00:59 447 查看


Number Sequence



Time Limit: 1000ms Memory limit: 65535K 有疑问?点这里^_^


题目描述

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

输入

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

输出

For each test case, print the value of f(n) on a single line.

示例输入

1 1 3
1 2 10
0 0 0


示例输出

2
5


来源

ZJCPC2004

#include<stdio.h>
int main()
{
int i,j,n,m,k,t,f1,f2,f3;
while(scanf("%d %d %d",&n,&m,&k)&&(n||m||k))
{
f1=1;
f2=1;
if(k==1)
printf("%d\n",f1);
if(k==2)
printf("%d\n",f2);
if(k>=3)
{
for(i=3;i<=k;i++)
{
f3=(f2*n+f1*m)%7;
f1=f2;
f2=f3;
}
printf("%d\n",f3);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: