您的位置:首页 > 其它

poj2553The Bottom of a Graph【tarjan中SCC出度是1】

2015-11-10 18:21 253 查看
Description

We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges.
Then G=(V,E) is called a directed graph. 

Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1).
Then p is called a path from vertex v1 to vertex vn+1 in Gand we say that vn+1 is reachable from v1, writing (v1→vn+1). 

Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of
all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.
Input

The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer
numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with
the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.
Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.


Sample Input
3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output
1 3
2

Source

Ulm Local 2003

rt,题里问的就是这个意思,各种纠结的调了好久 1A的喜悦的难以言表的~~要不是因为从0开始还是从一开始这个问题(主要还是没注意模板的写法 (⊙﹏⊙)b)而且记得写文件就更好了

/*************
poj2553
2015.11.10
1324K 172MS G++ 2299B
*************/
#include <iostream>
#include<cstdio>
#include<stack>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 5005
vector<int>G[maxn];
int pre[maxn],lowlink[maxn],sccno[maxn],dfs_clock,scc_cnt;
stack<int>S;
int in0[maxn],out0[maxn];
int num[5006];
void dfs(int u)
{
pre[u]=lowlink[u]=++dfs_clock;
S.push(u);
for(int i=0;i<G[u].size();i++)
{
int v=G[u][i];
if(!pre[v])
{
dfs(v);
lowlink[u]=min(lowlink[u],lowlink[v]);
}
else if(!sccno[v])
lowlink[u]=min(lowlink[u],pre[v]);
}
if(lowlink[u]==pre[u])
{
scc_cnt++;
// printf("序号是%d ,里面有",scc_cnt);
for(;;)
{
int x=S.top();S.pop();
sccno[x]=scc_cnt;
//printf("%d ",x);
if(x==u) break;
}
}
}
void find_scc(int n)
{
dfs_clock=scc_cnt=0;
memset(sccno,0,sizeof(sccno));
memset(pre,0,sizeof(pre));
for(int i=0;i<n;i++) if(!pre[i]) dfs(i);
}
int main()
{
// freopen("cin.txt","r",stdin);
int n,m;
while(~scanf("%d",&n))
{
if(n==0) break;
scanf("%d",&m);
for(int i=0;i<n;i++) G[i].clear();
for(int i=0;i<m;i++)
{
int u,v;
scanf("%d%d",&u,&v);u--;v--;
G[u].push_back(v);
}
find_scc(n);
for(int i=1;i<=scc_cnt;i++) in0[i]=out0[i]=1;
// printf("scc_cnt=%d ",scc_cnt);
for(int u=0;u<n;u++)
{
for(int i=0;i<G[u].size();i++)
{
int v=G[u][i];
if(sccno[u]!=sccno[v]) in0[sccno[v]]=out0[sccno[u]]=0;
}
}
int a=0,cnt=0;
for(int i=1;i<=scc_cnt;i++)
{
if(out0[i])
{
// printf("i=%d ",i);
for(int j=0;j<n;j++)
{
if(sccno[j]==i)
num[cnt++]=j+1;
}
}
}
//printf("cnt=%d ",cnt);
if(cnt)
{
sort(num,num+cnt);
printf("%d",num[0]);
for(int i=1;i<cnt;i++) printf(" %d",num[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: