您的位置:首页 > 其它

poj2955

2015-11-09 20:47 246 查看
Brackets

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4686 Accepted: 2484
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6


这道题用dp可以解决,dp方程可以从代码中获得。
以ac的代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
#define N 110

char ch
;
int dp

;

int main(){
int length;
while(scanf("%s",ch)!=EOF&&ch[0]!='e'){
length=strlen(ch);
memset(dp,0,sizeof(dp));
for(int i=2;i<=length;i++){
for(int j=0;j<=length-i;j++){
dp[j][j+i-1]=dp[j][j+i-2];

if(ch[j+i-1]=='('||ch[j+i-1]=='['){
continue;
}
for(int k=j;k<j+i-1;k++){
if((ch[k]=='('&&ch[j+i-1]==')')||(ch[k]=='['&&ch[j+i-1]==']')){
if(k!=i+j-2&&k!=j){
dp[j][j+i-1]=max(dp[j][j+i-1],dp[j][k-1]+dp[k+1][i+j-2]+2);
}
else if(k!=j){
dp[j][j+i-1]=max(dp[j][j+i-1],dp[j][k-1]+2);
}
else if(k!=i+j-2){
dp[j][j+i-1]=max(dp[j][j+i-1],dp[j+1][j+i-2]+2);
}
else{
dp[j][j+i-1]=max(dp[j][j+i-1],2);
}
}
}
}
}

printf("%d\n",dp[0][length-1]);
}

return 0;
}
参考链接: http://www.cnblogs.com/ziyi--caolu/archive/2013/08/04/3236035.html
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: