您的位置:首页 > 其它

hdu 1358 Period nex[]求循环节

2015-11-08 10:49 148 查看


Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5048    Accepted Submission(s): 2441


[align=left]Problem Description[/align]
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the
largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

[align=left]Input[/align]
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line,
having the number zero on it.

 

[align=left]Output[/align]
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the
prefix sizes must be in increasing order. Print a blank line after each test case.

 

[align=left]Sample Input[/align]

3
aaa
12
aabaabaabaab
0

 

[align=left]Sample Output[/align]

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

 

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  3336 2203 1277 1867 1298 

对于以位置i结尾的前缀,其最小周期=i+1-nex[i+1];(利用严蔚敏未改进的KMP中的nex,不是我自己yy的那种)
#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<algorithm>
#include<queue>
#include<set>
#include<vector>
#include<map>
#include<stack>
//typedef long long ll;
//by yskyskyer123
using namespace std;
const int maxm=1000000+20;
int m;
char M[ maxm];
int nex[maxm];

void getnex()
{
int j=nex[1]=0;
for(int i=1;i<=m;)
{
while(j&&M[i]!=M[j])  j=nex[j];

nex[++i]=++j;
}
/*
for(int i=1;i<=m+1;i++)
printf("%d :%d ",i,nex[i]);
putchar('\n');
*/
}

void work()
{
for(int i=2;i<=m;i++)
{
int circle=i+1-nex[i+1];
if(i%circle||i==circle)  continue;
printf("%d %d\n",i,i/circle);
}
}

int main()
{
int i,j,kase=0;
while(~scanf("%d",&m)&&m)
{
scanf("%s",M+1);
printf("Test case #%d\n",++kase);
getnex();
work();
putchar('\n');
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: