您的位置:首页 > 其它

HDOJ 1962 Card Game Cheater 【同田忌赛马】

2015-11-07 19:58 369 查看

Card Game Cheater

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 230 Accepted Submission(s): 163



[align=left]Problem Description[/align]
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards
face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for
each i ∈ {1, . . . , k}):

• If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.

• If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.

• A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.

• If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards
Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

[align=left]Input[/align]
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k ≤ 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has
not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are
the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD

[align=left]Output[/align]
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

[align=left]Sample Input[/align]

3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D


[align=left]Sample Output[/align]

1
1
2


恩,题目大意就是说,相当于扑克牌,然后从2开始到9,之后 ' A ' 表示的应该是王,大小不同的按大小比,大小相同的,心形的大于桃形的大于方片的大于梅花的。恩,是两

个人的牌,第一个人的牌已拍好顺序,第二个人的牌还未排顺序,若第二个人的牌大于第一个人的牌则加一分,这里问第二个人最多能加多少分。(可能翻译不太好,见谅)

(代码比较挫。。。。)

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct lnode
{
int v,c;
};
lnode nodea[30],nodeb[30];
int cmp(lnode a,lnode b)
{
if(a.v!=b.v)
return a.v<b.v;
else
return a.c<b.c;
}
int judge(lnode a,lnode b)
{
if(a.v!=b.v)
{
if(a.v>b.v)
return 1;
else
return 0;
}
else
{
if(a.c>b.c)
return 1;
else
return 0;
}
}
int main()
{
int t,n,s;
char a,b;
scanf("%d",&t);
while(t--)
{
s=0;
scanf("%d",&n);
int i=0,j=0;
for(int k=0;k<n;++k)
{
getchar();
scanf("%c%c",&a,&b);
if(b=='H')
nodea[i].c=4;
else if(b=='S')
nodea[i].c=3;
else if(b=='D')
nodea[i].c=2;
else
nodea[i].c=1;
if(a=='A')
nodea[i].v=14;
else if(a=='T')
nodea[i].v=10;
else if(a=='J')
nodea[i].v=11;
else if(a=='Q')
nodea[i].v=12;
else if(a=='K')
nodea[i].v=13;
else
nodea[i].v=a-'0';
i++;
}
for(int k=0;k<n;++k)
{
getchar();
scanf("%c%c",&a,&b);
if(b=='H')
nodeb[j].c=4;
else if(b=='S')
nodeb[j].c=3;
else if(b=='D')
nodeb[j].c=2;
else
nodeb[j].c=1;
if(a=='A')
nodeb[j].v=14;
else if(a=='T')
nodeb[j].v=10;
else if(a=='J')
nodeb[j].v=11;
else if(a=='Q')
nodeb[j].v=12;
else if(a=='K')
nodeb[j].v=13;
else
nodeb[j].v=a-'0';
j++;
}
sort(nodea,nodea+i,cmp);
sort(nodeb,nodeb+j,cmp);
int m=i;i=j=0;
while(i<m&&j<m)
{
if(judge(nodeb[j],nodea[i]))
{
s++;
i++,j++;
}
else
j++;
}
printf("%d\n",s);
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: