您的位置:首页 > 其它

Can you solve this equation?

2015-11-06 15:56 141 查看
[align=left]Problem Description[/align]Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;Now please try your lucky.[align=left]Input[/align]The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);[align=left]Output[/align]For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.[align=left]Sample Input[/align]
2
100
-4
[align=left]Sample Output[/align]
1.6152
No solution!

[code]#include<stdio.h>
#include<math.h>
double fun(double x)
{
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}
int main()
{
int t;
double y,mid;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
if(fun(0)>y||fun(100)<y)   //怎么感觉应该是fun(0)>y
{
printf("No solution!\n");
}
else
{
double l=0,r=100;
while(r-l>1e-9)	//要保证精度
{
mid=(r+l)/2;
if(fun(mid)>y) r=mid;
else l=mid;
}
printf("%.4lf\n",mid);
}
}
return 0;
}
[/code]
此问题刚开始可能找不到头脑,不知道从哪下手,重要的在于转化思想,用二分法做着实很有效。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: