您的位置:首页 > 其它

1096. Consecutive Factors

2015-11-06 15:30 176 查看


1096. Consecutive Factors (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number
of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing
order, and 1 is NOT included.
Sample Input:
630

Sample Output:
3
5*6*7

#include<stdio.h>
#include<vector>
#include<math.h>
using namespace std;

int main()
{
int n = 0;
scanf("%d", &n);
vector<int> v;
if(n == 2 || n == 3 || n == 5)
{
printf("1\n%d", n);
return 0;
}
//case6:超时在于计算整除的时候,判断条件,如果是i*i<=n,这样会超时的
int num = (int)sqrt(n);
for(int i = 2; i <= num; i ++)
if(n % i == 0)
v.push_back(i);
v.push_back(n);
int maxLen = 0, maxFactor = n;
int tmpLen = 0, tmpFactor = 0;

for(int i = 0; i < v.size(); i ++)
{
num = n;
tmpFactor = v[i];
tmpLen = 0;

while(num%tmpFactor == 0)
{
tmpLen ++;
num /= tmpFactor;
tmpFactor ++;
}

if(tmpLen > maxLen)
{
maxLen = tmpLen;
maxFactor = v[i];
}
}

printf("%d\n", maxLen);
for(int i = 0; i < maxLen; i ++)
{
if(i)
printf("*%d", maxFactor);
else
printf("%d", maxFactor);
maxFactor++;
}
printf("\n");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: