您的位置:首页 > 其它

统计难题【字典树】

2015-11-05 23:04 204 查看
字典树题目,上题,输入字典,输入字符串,给出对应字符串为前缀的数量,


统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)

Total Submission(s): 26391    Accepted Submission(s): 10701


Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

 

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

 

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

 

Sample Output

2
3
1
0

直接字典树,然后每个都统计一次size,每添加/经过一个结点都size++

#include<stdio.h>
#include<string.h>
#include<iostream>
struct node
{
int size;
node *ch[26];
node()
{
size = 0;
for(int i = 0 ; i < 26 ; i++)
{
ch[i] = NULL;
}
}
};
/de *root = new node;
node root[100005];
node *current,*newnode;
void INSERT(char *s)
{
int len = strlen(s);
int i,m;
current = root;
for(i = 0 ; i < len ;i++)
{
m = s[i]-'a';
if(current->ch[m]!=NULL)
{
current = current->ch[m];
(current->size)++;
}
else
{
newnode = new node;
(newnode->size)++;
current->ch[m] = newnode;
current = newnode;
}
}
}
int QUERY(char *s)
{
int i,m;
current = root;
for(i = 0 ; i < strlen(s);i++)
{
m = s[i]-'a';
if(current->ch[m]==NULL)
return 0;
current = current->ch[m];
}
return current->size;
}
using namespace std;
int main()
{
char str[20];
while(gets(str),strcmp(str,""))
{
INSERT(str);
}
while(gets(str)!=NULL)
{
printf("%d\n",QUERY(str));
}
delete [] newnode;
newnode = NULL;
return 0;
}

提交的时候发现了不知道为什么MLE,C++交就AC了,但是的确字典树是相当耗内存
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: