您的位置:首页 > 其它

pat 1075 PAT Judge

2015-11-05 17:14 190 查看
The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105),
the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the
i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th
problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in
increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.
Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <map>
#include <algorithm>
#include <string>
using namespace std;

#define MAXX 10010

struct User
{
int id;
int points[6];
int total;
int flag;
};

int score[6];
int n, k, m;

vector<User> vec;

bool cmp(const User &a, const User &b) {
if(a.flag != b.flag) {
return a.flag > b.flag;
} else {
int total_a = 0, total_b = 0;
int cnt_a = 0, cnt_b = 0;

for (int i = 1; i <= k; ++i)
{
if(a.points[i] >= 0)
total_a += a.points[i];
if(b.points[i] >= 0)
total_b += b.points[i];

if(a.points[i] == score[i]) cnt_a += 1;
if(b.points[i] == score[i]) cnt_b += 1;
}

if(total_a != total_b) {
return total_a > total_b;
} else if(cnt_a != cnt_b){
return cnt_a > cnt_b;
} else {
return a.id < b.id;
}
}
}

void print() {
int pre = 0, num=0;

for (int i = 1; i <= k; ++i)
{
pre += score[i];
}

pre += 1;

for (int i = 0; i < n; ++i)
{
int cnt = 0;
int end = 0;

for (int j = 1; j <= k; ++j)
{
if(vec[i].points[j] >= 0)
cnt += vec[i].points[j];
end += vec[i].points[j];
}

if(end == -k) break;
if(cnt < pre) {
num = i+1;
}
printf("%d ", num);
printf("%05d %d", vec[i].id, cnt);

for (int j = 1; j <= k; ++j)
{
if(vec[i].points[j] == -1) {
printf(" -");
} else {
printf(" %d", vec[i].points[j]);
}

}
printf("\n");
pre = cnt;
}
}
int main() {
scanf("%d %d %d", &n, &k, &m);
map<int, int> exited;

for (int i = 0; i < n; ++i)
{
User user;
user.id = i+1;
user.total = 0;
user.flag = 0;
for (int j = 1; j <= k; ++j)
{
user.points[j] = -1;
}
vec.push_back(user);
}

for (int i = 1; i <= k; ++i)
{
scanf("%d", &score[i]);
}

for (int i = 1; i <= m; ++i)
{
int id, item, pits;
scanf("%d %d %d", &id, &item, &pits);
if(pits != -1) {
vec[id-1].flag = 1;
} else {
if(vec[id-1].points[item] <= 0)
vec[id-1].points[item]=0;
}
if(pits>=vec[id-1].points[item]) {
vec[id-1].points[item]=pits;
}

}

sort(vec.begin(), vec.end(), cmp);
print();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: