您的位置:首页 > 其它

BestCoder Round #60 GT and numbers (模拟)

2015-11-02 19:08 239 查看


GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 133    Accepted Submission(s): 39

Problem Description

You are given two numbers N and M.

Every step you can get a new N in
the way that multiply N by
a factor of N.

Work out how many steps can N be
equal to M at
least.

If N can't be to M forever,print −1.

 

Input

In the first line there is a number T.T is
the test number.

In the next T lines
there are two numbers N and M.

T≤1000, 1≤N≤1000000,1≤M≤263.

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.

 

Output

For each test case,output an answer.

 

Sample Input

3
1 1
1 2
2 4

 

Sample Output

0
-1
1

 

Source

BestCoder Round #60

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  5508 5507 5506 5503 5502 

 

解析:n要变成m,即可表示为:n*(m/n)==m

           以n=2  m=32为例演示这个转换过程:

                 n=2  m/n=16

                1.  n=n*gcd(n,m/n)=4

                2.  n=n*gcd(n,m/n)=16

                3.  n=n*gcd(n,m/n)=32

          其实就是一直重复 n=n*gcd(n,m/n) 这个过程,直到n==m。        

代码:

#include<cstdio>
#include<iostream>
using namespace std;

typedef unsigned long long ull;
ull n,m;

ull gcd(ull x,ull y)
{
ull t;
while(y!=0)t=x%y,x=y,y=t;
return x;
}

void work()
{
if(n==m)
{
cout<<0<<endl;
return;
}
if(n==1 || m%n)
{
cout<<-1<<endl;
return;
}

ull ans=0,k; m=m/n;
while(m>1)
{
k=gcd(n,m);
if(k==1)
{
cout<<-1<<endl;
return;
}
n*=k,m/=k,ans++;
}
cout<<ans<<endl;
}

int main()
{
freopen("2.in","r",stdin);
int t;
cin>>t;
while(t--)
{
cin>>n>>m;
work();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: