您的位置:首页 > 其它

L - Huatuo's Medicine【ccpc】

2015-10-31 23:10 274 查看
L - Huatuo's Medicine
Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%lld
& %llu
Submit Status

Description

Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these bottles together.

However, there was a critical problem. When Huatuo arrived the patient's home, he took the chain out of his bag, and he could not recognize which bottle contains which type of medicine, 

but he remembers the order of the bottles on the chain.

Huatuo has his own solution to resolve this problem. When he need to bring $2$ types of medicines, E.g. 
A
 and 
B
, he will put 
A
 into one bottle and put 
B
 into two bottles. 

Then he will chain the bottles in the order of 
-B-A-B-
. In this way, when he arrived the patient's home, he knew that the bottle in the middle is medicine 
A
 and the bottle on 

two sides are medicine 
B
.

Now you need to help Huatuo to work out what's the minimal number of bottles needed if he want to bring $N$ types of medicine.

Input

The first line of the input gives the number of test cases, $T$($1\leq T\leq 100$). $T$ lines follow. Each line consist of one integer $N$($1\leq N\leq 100$), 

the number of types of the medicine.

Output

For each test case, output one line containing 
Case #x: y
, where $x$ is the test case number (starting from $1$) and $y$ is the minimal number of bottles Huatuo needed.

Sample Input



2

Sample Output

Case #1: 3

#include<stdio.h>
int main()
{
long long t,n,k=1;
scanf("%lld",&t);
while(t--){
scanf("%lld",&n);
printf("Case #%lld: %lld\n",k++,2*(n-1)+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  L - Huatuos Medicine