您的位置:首页 > 其它

hdoj--1028--Ignatius and the Princess III(母函数)

2015-10-31 22:23 483 查看

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16242    Accepted Submission(s): 11445


[align=left]Problem Description[/align]
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

  N=a[1]+a[2]+a[3]+...+a[m];

  a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

  4 = 4;

  4 = 3 + 1;

  4 = 2 + 2;

  4 = 2 + 1 + 1;

  4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 

[align=left]Input[/align]
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

 

[align=left]Output[/align]
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

 

[align=left]Sample Input[/align]

4
10
20

 

[align=left]Sample Output[/align]

5
42
627

 

[align=left]Author[/align]
Ignatius.L
 
#include<stdio.h>
#include<string.h>
#define max 100+30
int main()
{
int c1[max],c2[max];
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<=n;i++)
{
c1[i]=1;
c2[i]=0;
}
for(int i=2;i<=n;i++)//从第二个多项式开始乘
{
for(int j=0;j<=n;j++)//在第一个多项式中的每一项与后边的相乘
for(int k=0;k+j<=n;k+=i)//在第i个多项式中的每一项与前边的相乘
c2[k+j]+=c1[j];
for(int j=0;j<=n;j++)
{
c1[j]=c2[j];//更新现在第一个多项式中的每一项的系数
c2[j]=0;
}
}
printf("%d\n",c1
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: