您的位置:首页 > 其它

最短路径___MPI Maelstrom(Poj 1502)

2015-10-31 08:38 429 查看
Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication
subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.

``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors
that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages
don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time
required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that
1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to
node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus
only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10


Sample Output

35


题意:N个处理器要进行信息传递,处理器i传递信息给自己不需要时间,处理器i与处理器j之间相互传递信息的时间是一样的,不同处理器之间传递信息所需要的时间由一个矩阵的下三角给出。若矩阵对应位置为x,则说明相应的两个处理器之间无法传递信息。让你来求从点1到其他点所花费最短时间集里面的的最大值。

思路:Dijkstra

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define N 110
#define INF 999999999
int mpt

;
int visit
;
int dis
;
int n;
void Dijkstra(int x,int n,int* visit,int mt

)
{
memset(visit,0,sizeof(visit));
visit[1] = 1;
int i,j,Min,Minj;
for(i = 0 ; i < n ; i ++)
{

Min = INF;Minj = -1;
for(j = 1 ; j <= n ; j ++)
{
if(visit[j])continue;
if(dis[j] < Min)
{
Min = dis[j];
Minj = j;
}
}
if(Minj == -1) break;
visit[Minj] = 1;
for(j = 1; j <= n ; j ++)
{
if(dis[j] > dis[Minj] + mpt[Minj][j]) dis[j] = dis[Minj] + mpt[Minj][j];
}
}
}
int main()
{
int i,j;
char str[10];
while(scanf("%d",&n)!=EOF)
{
for(i = 1 ; i <= n ; i ++)
{
for(j = 1 ; j <= n ; j ++)
{
if(i == j){
mpt[i][j] == 0;
continue;
}
if(j > i)break;
scanf("%s",str);
if(str[0] == 'x'){
mpt[i][j] = mpt[j][i] = INF;
}
else
{
mpt[i][j] = mpt[j][i] = atoi(str);
}
}
}
for(i = 1; i <= n ; i ++) dis[i] = mpt[1][i];

Dijkstra(1,n,visit,mpt);
int ans = 0;

for( i = 1; i <= n ; i ++)
if( dis[i] != INF && dis[i] > ans) ans = dis[i];
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: