您的位置:首页 > 其它

HDU 4081—— Qin Shi Huang's National Road System——————【次小生成树、prim】

2015-10-31 08:08 281 查看

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5608 Accepted Submission(s): 1972


[align=left]Problem Description[/align]
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.



Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

[align=left]Input[/align]
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.

[align=left]Output[/align]
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

[align=left]Sample Input[/align]

2

4

1 1 20
1 2 30
200 2 80

200 1 100

3

1 1 20

1 2 30

2 2 40

[align=left]Sample Output[/align]

65.00

70.00

[align=left]Source[/align]
2011 Asia Beijing Regional Contest

题目大意:给你n,表示城市个数,然后给你n个城市的坐标及该城市中的人口数量。让连接这n个城市用n-1条边连接,且距离和最短,距离越长花费越大。数字A表示,用魔法路连接的两个城市的人口的和,B表示除了该魔法路以外的其他路的长度和。求A/B的比率最小值是多少。魔法路没有路长。

解题思路:考虑让除了魔法路以外的路长和最小,那么我们可以从最小生成树中删除一条最长路径。枚举删除任意两点间的最长路,更新出最小比率。

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 1010;
double cost[maxn][maxn];
struct Coor{
double x, y;
int peo;
}cors[maxn];
double distan(Coor a,Coor b){
double dx,dy;
dx = a.x - b.x;
dy = a.y - b.y;
return sqrt( dx*dx + dy*dy );
}
int vis[maxn], pre[maxn] ,used[maxn][maxn];
double maxcost[maxn][maxn], lowc[maxn];
double prim(int n){
memset(vis,0,sizeof(vis));
memset(used,0,sizeof(used));
for(int i = 0; i <= n; i++){
for(int j = 0; j <= n; j++){
maxcost[i][j] = 0;
}
}
//    memset(maxcost,0,sizeof(maxcost));
//    memset(lowc,0,sizeof(lowc));
double retsum = 0;
vis[0] = 1;
for(int i = 0; i < n; i++){
lowc[i] = cost[0][i];
pre[i] = 0;
}
for(int i = 1; i < n; i++){
int s = -1;
double minc = 1.0*INF;
for(int j = 0; j < n; j++){
if(!vis[j] && lowc[j] < minc){
minc = lowc[j];
s = j;
}
}
if(s == -1){
return -1;
}
retsum += minc;
int pa = pre[s];
vis[s] = 1;
for(int j = 0; j < n; j++){
if(vis[j]&&j != s){
maxcost[s][j] = maxcost[j][s] = max(maxcost[pa][j],cost[pa][s]);
}
}
used[s][pa] = used[pa][s] = 1;
for(int j = 0; j < n; j++){
if(!vis[j] && lowc[j] > cost[s][j]){
lowc[j] = cost[s][j];
pre[j] = s;
}
}
}
return retsum;
}
int main(){
int T,n;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
for(int i = 0; i <=n; i++){
for(int j = 0; j <= n; j++){
cost[i][j] = 1.0*INF;
}
}
for(int i = 0; i < n; i++){
scanf("%lf%lf%d",&cors[i].x,&cors[i].y,&cors[i].peo);
for(int j = 0; j < i; j++){
cost[i][j] = cost[j][i] = distan(cors[i],cors[j]);
}
}
double mst = prim(n);
double maxr = 0;
for(int i = 0; i < n; i++){
for(int j = 0; j < n; j++){
if(i == j) continue;
int tmp = (cors[i].peo + cors[j].peo);
if(!used[i][j]){
maxr = max( maxr, (1.0*tmp)/(mst-maxcost[i][j]));
}else{
maxr = max(maxr,(1.0*tmp)/(mst - cost[i][j]));
}
}
}
printf("%.2lf\n",maxr);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: