您的位置:首页 > 其它

1044. 火星数字(20)

2015-10-30 14:09 197 查看
火星人是以13进制计数的:

地球人的0被火星人称为tret。

地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。

火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam

输出样例:
hel mar
may
115
13

----------------------华丽的分割线-----------------------
分析:注意13的倍数不需要输出tret
代码:
#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include <stdlib.h>

const char low[13][5] = {"tret","jan", "feb", "mar", "apr", "may", "jun",
"jly", "aug", "sep", "oct", "nov", "dec"};
const char high[13][5] = {"\0","tam", "hel", "maa", "huh", "tou", "kes",
"hei", "elo", "syy", "lok", "mer", "jou"};

char left[4];
char right[5];

int chartodec(char c[]);

int main(void)
{
int N,i,length;
int first,second;
char input[10];

scanf("%d\n",&N);
for(i=0;i<N;++i)
{
gets(input);
length = strlen(input);
if(length > 4)
{
strcpy(left,input);
left[3] = '\0';
strcpy(right,input+4);
right[length-4] = '\0';
printf("%d\n",chartodec(left)+chartodec(right));
}
else
{
if(isdigit(input[0]))
{
if(atoi(input) > 0)
{
first = atoi(input) / 13;
second = atoi(input) % 13;
if(first != 0)
printf("%s",high[first]);
if(first != 0 && second != 0)
printf(" ");
if(second != 0)
printf("%s",low[second]);
printf("\n");
}
else
{
printf("%s\n",low[0]);
}
}
else
{
printf("%d\n",chartodec(input));
}
}
}

return 0;
}

int chartodec(char c[])
{
int i;
for(i=0;i<13;++i)
{
if(strcmp(c,low[i]) == 0)
break;
}
if(i != 13)
return i;

for(i=0;i<13;++i)
{
if(strcmp(c,high[i]) == 0)
break;
}
if(i != 13)
return i*13;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: