您的位置:首页 > 其它

1004成绩排名

2015-10-30 08:27 330 查看
读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
... ... ...
第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:
Mike CS991301
Joe Math990112
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
struct student{
string name;
string xuehao;
int grade;
};
bool cmp(const student & temp1,const student & temp2){
if(temp1.grade < temp2.grade)
return true;
else
return false;
}
int main(){
int n;
cin>>n;
vector<student>temp;
for(int i = 0;i<n;i++){
student haha;
cin>>haha.name>>haha.xuehao>>haha.grade;
temp.push_back(haha);
}
sort(temp.begin(),temp.end(),cmp);
cout<<temp[n-1].name<<" "<<temp[n-1].xuehao<<endl;
cout<<temp[0].name<<" "<<temp[0].xuehao<<endl;
return 0;
}
/*
写比较函数的时候,参数要写成const类型的引用,否则会出现编译错误
*/


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: