您的位置:首页 > 其它

poj Intersecting Lines 1269 (数学几何 判断两条直线是否相交)

2015-10-29 22:13 323 查看
Intersecting Lines

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12837 Accepted: 5702
Description
We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are
on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.

Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input
The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in
the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output
There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect:
none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".
Sample Input
5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output
INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

//题意

分别给出直线l1和l2上的两点。l1(x1,y1)(x2,y2)

l2 (x3,y3)(x4,y4)

让你判断l1与l2的关系。

若有交点输出交点坐标

#include<stdio.h>
#include<string.h>
#include<math.h>
#define E 1e-10
struct zz
{
double x;
double y;
}b,e,bb,ee;
int main()
{
int t;
double a,b1,c;
double aa,bb1,cc;
scanf("%d",&t);
printf("INTERSECTING LINES OUTPUT\n");
while(t--)
{
scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&b.x,&b.y,&e.x,&e.y,&bb.x,&bb.y,&ee.x,&ee.y);
a=b.y-e.y;
b1=e.x-b.x;
c=e.y*b.x-e.x*b.y;
aa=bb.y-ee.y;
bb1=ee.x-bb.x;
cc=ee.y*bb.x-ee.x*bb.y;
if(abs((b.x-e.x)*(bb.y-ee.y)-(b.y-e.y)*(bb.x-ee.x))<=E)//判断平行
{
if(abs((e.x-b.x)*(bb.y-b.y)-(e.y-b.y)*(bb.x-b.x))<E)//判断重合
printf("LINE\n");
else
printf("NONE\n");		}
else//求出交点
{
double x=(c*bb1-cc*b1)/(aa*b1-a*bb1);
double y=(aa*c-a*cc)/(a*bb1-aa*b1);
printf("POINT %.2f %.2f\n",x,y);
}
}
printf("END OF OUTPUT\n");
return 0;
}

//改进了一下,容易理解

#include<stdio.h>
#include<string.h>
#include<math.h>
#define E 1e-10
struct zz
{
double x;
double y;
}b,e,bb,ee;
int main()
{
int t;
double a,b1,c;
double aa,bb1,cc;
scanf("%d",&t);
printf("INTERSECTING LINES OUTPUT\n");
while(t--)
{
scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&b.x,&b.y,&e.x,&e.y,&bb.x,&bb.y,&ee.x,&ee.y);
a=b.y-e.y;
b1=e.x-b.x;
c=e.y*b.x-e.x*b.y;
aa=bb.y-ee.y;
bb1=ee.x-bb.x;
cc=ee.y*bb.x-ee.x*bb.y;
if(a*bb1==aa*b1)//判断平行
{
if((a*bb.x+b1*bb.y+c)*(a*ee.x+b1*ee.y+c)<=E)//判断重合
printf("LINE\n");
else
printf("NONE\n");
}
else//求出交点
{
double x=(c*bb1-cc*b1)/(aa*b1-a*bb1);
double y=(aa*c-a*cc)/(a*bb1-aa*b1);
printf("POINT %.2f %.2f\n",x,y);
}
}
printf("END OF OUTPUT\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: