您的位置:首页 > 其它

Sum Problem

2015-10-29 11:34 369 查看
Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1

100

Sample Output

1

5050

#include<stdio.h>
int main()
{
int i,n,sum=0;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;++i)
sum=sum+i;
printf("%d\n\n",sum);
sum=0;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj