您的位置:首页 > 其它

HDOJ-2058 The sum problem

2015-10-28 15:33 453 查看
[align=left]Problem Description[/align]
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

[align=left]Input[/align]
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

[align=left]Output[/align]
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

[align=left]Sample Input[/align]

20 10
50 30
0 0


[align=left]Sample Output[/align]

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]------------------------------------------------------------------------------------------------------------------------------------由于这道题涉及的数字会比较大,刚开始我使用暴力超时,重新思考了一下,发现了新的思路。
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
__int64 m ,n;
while(cin>>n>>m,n||m)
{
__int64 a,k;
for(k=(int)sqrt(2*m);k>0;k--)//因为1+2+。。。+(2*m)^1/2>m;所一和为m的元素个数应该小于等于(2*m)^1/2;
{
a=m/k-(k-1)/2;//假设从a开始一直加到a+k-1,一共k个元素和为m,可以计算出a;
if((2*a-1+k)*k==2*m) //(2*m)^1/2可能不是整数,判断是有必要的;
cout<<"["<<a<<","<<k+a-1<<"]"<<endl;
}
cout<<endl;

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: