您的位置:首页 > 其它

HDOJ 题目3257 Hello World!(模拟)

2015-10-26 13:28 447 查看

Hello World!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 554 Accepted Submission(s): 208



[align=left]Problem Description[/align]
Your task is to print ... er ... "Hello World" ... in a fantastic way -- using a beautiful font.

I've sent you a nice font for you to use, but I'm too busy to tell you how. Can you help yourself?

[align=left]Input[/align]
The first line contains a single integer T (T <= 20), the number of test cases.

Each case begins with an integer C (1 <= C <= 80) in a single line, then each of the following C lines contains five two-digit numbers in hex (letters will be in uppercase). Don't ask me what they mean, I'm too busy...

[align=left]Output[/align]
For each test case, print the case number in the first line, then followed by a blank line.

After that, print all T characters. Use a single blank column of spaces between two consecutive characters. Each line should have exactly 6C-1 character (again, don't ask me why).

Don't forget to print another blank line after the output of each test case.

[align=left]Sample Input[/align]

2
11
7F 08 08 08 7F
38 54 54 54 18
00 41 7F 40 00
00 41 7F 40 00
38 44 44 44 38
00 00 00 00 00
3F 40 38 40 3F
38 44 44 44 38
7C 08 04 04 08
00 41 7F 40 00
38 44 44 48 7F
5
14 08 3E 08 14
04 02 01 02 04
40 40 40 40 40
04 02 01 02 04
14 08 3E 08 14


[align=left]Sample Output[/align]

Case 1:

#   #        ##    ##               #   #              ##       #
#   #         #     #               #   #               #       #
#   #  ###    #     #    ###        #   #  ###  # ##    #    ## #
##### #   #   #     #   #   #       # # # #   # ##  #   #   #  ##
#   # #####   #     #   #   #       # # # #   # #       #   #   #
#   # #       #     #   #   #       # # # #   # #       #   #   #
#   #  ###   ###   ###   ###         # #   ###  #      ###   ####

Case 2:

#           #
#    # #         # #    #
# # # #   #       #   # # # #
###                     ###
# # #                   # # #
#                       #
#####


[align=left]Source[/align]
2009 Asia Regional Ningbo Online

[align=left]Recommend[/align]
wujianhua | We have carefully selected several similar problems for you: 3259 3251 3252 3253 3254
7F的二进制是1111111
所有第一列7个#。。
ac代码

152564452015-10-26 13:24:13Accepted32570MS1716K1631 BC++Who_you?
#include<stdio.h>
#include<string.h>
char str[10][500];
int n;
void init()
{
int i,j;
for(i=0;i<7;i++)
for(j=0;j<6*n-1;j++)
str[i][j]=' ';
}
int to10(char *s)
{
int ans=0;
int m=1;
int i;
for(i=1;i>=0;i--)
{
if(s[i]>='0'&&s[i]<='9')
{
ans+=(s[i]-'0')*m;
}
else
ans+=(s[i]-'A'+10)*m;
m*=16;
}
return ans;
}
int main()
{
int cas,c=0;
scanf("%d",&cas);
while(cas--)
{
//    int n;
scanf("%d",&n);
init();
char s[5];
int i,j,num=0;
for(i=0;i<n;i++)
{
for(j=0;j<5;j++)
{
scanf("%s",s);
int res=to10(s);
int deep=0;
while(res)
{
if(res%2==1)
str[deep][num]='#';
res/=2;
deep++;
}
num++;
}
num++;
}
printf("Case %d:\n\n",++c);
for(i=0;i<7;i++)
{
for(j=0;j<6*n-1;j++)
{
printf("%c",str[i][j]);
}
printf("\n");
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: