您的位置:首页 > 其它

周赛 题 1 light oj 1005【2015/10/24】

2015-10-25 19:28 357 查看
A - 楼下水题
Crawling in process...Crawling failedTime Limit:1000MS Memory
Limit:
32768KB 64bit IO Format:%lld & %llu
Submit
Status
Practice
LightOJ 1005

Description

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure,
the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rookR1 and
R2 are in attacking positions whereR1 and
R3 are not. R2 and
R3
are also in non-attacking positions.



Now, given two numbers n and k, your job is to determine the number of ways one can putk rooks on an
n x n chessboard so that no two of them are in attacking positions.

Input

Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output

For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than1017.

Sample Input

8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output

Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0

分析:

这道题关键是找规律,规律sum=Cn/m* An/m.

代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
int t;
long long n,m;
int cnt=0;
long long C,A;
long long sum;
scanf("%d",&t);
while(t--)
{
C=1,A=1;
sum=0;
long long i,j;
scanf("%lld%lld",&n,&m);
printf("Case %d: ",++cnt);
if(m==1&&n>=m){
printf("%lld\n",n*n);
continue;
}
if(m>n)
{
printf("0\n");
continue;}
else{
for(i=n;i>n-m;i--)
{
A*=i;
}
for(j=m;j>=1;j--)
{
C*=j;
}
sum=A*(A/C);
printf("%lld\n",sum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: