您的位置:首页 > 其它

1084. Broken Keyboard (20)

2015-10-22 10:07 204 查看

1084. Broken Keyboard (20)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital
numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es

Sample Output:
7TI


http://www.patest.cn/contests/pat-a-practise/1084

ac1:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <iterator>
using namespace std ;

#define INF  999999
#define N 105

char s1
;
char s2
;
int len1 ;
int len2 ;

char upc(char c)
{
if(c >= 'a' && c <= 'z')
return c - 'a' + 'A' ;
return c ;
}

bool isExist(char c)
{
int i  ;
for(i = 0 ; i < len2; i ++)
{
if(upc(s2[i]) == upc(c))
return true ;
}
return false ;
}

int main()
{
//freopen("in.txt","r",stdin);
int i ;
gets(s1);
gets(s2);
len1 = strlen(s1);
len2 = strlen(s2);
map<char,int> mp ;
for(i = 0 ; i < len1 ; i ++)
{
char c = s1[i] ;
if( !isExist(c))
{
if(mp[upc(c)] == 0)
{
mp[upc(c)] = 1 ;
printf("%c" , upc(c)) ;
}
}
}
printf("\n");
return 0 ;
}


ac2:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <iterator>
using namespace std ;

#define INF  999999
#define N 105

char s1
;
char s2
;
int len1 ;
int len2 ;

char upc(char c)
{
if(c >= 'a' && c <= 'z')
return c - 'a' + 'A' ;
return c ;
}

int main()
{
//freopen("in.txt","r",stdin);
gets(s1);
gets(s2);
len1 = strlen(s1);
len2 = strlen(s2);
int i = 0 , j = 0 ;
map<char , int> mp ;
while( i < len1 && j < len2)
{
char c1 = upc(s1[i]) ;
char c2 = upc(s2[j]) ;
if(c1 == c2) // 相等则一起移动
{
i ++ ;
j ++ ;
}else{
i ++ ; // 不相等的时候 一定是缺了该字母 只要s1往后移
//printf("%c" , c1 ) ;
if(mp[c1] == 0)
{
mp[c1] = 1 ;
printf("%c" , c1 ) ; //  in the order of being detected
}
}
}
printf("\n") ;
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: