您的位置:首页 > 其它

POJ 3087 Shuffle'm Up

2015-10-20 18:51 232 查看
Shuffle'm Up

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7880 Accepted: 3615
Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips,
S1 and S2, each stack containing
C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from
S1
with a chip from
S2
as shown below for
C = 5:



The single resultant stack, S12, contains 2 *
C chips. The bottommost chip of S12 is the bottommost chip from
S2. On top of that chip, is the bottommost chip from
S1. The interleaving process continues taking the 2nd chip from the bottom of
S2 and placing that on
S12, followed by the 2nd chip from the bottom of
S1 and so on until the topmost chip from
S1 is placed on top of
S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost
C chips from S12 to form a new
S1 and the topmost
C chips from S12 to form a new
S2. The shuffle operation may then be repeated to form a new
S12.

For this problem, you will write a program to determine if a particular resultant stack
S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤
N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer
C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and
S2). The second line of each dataset specifies the colors of each of the
C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the
C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through
H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 *
C uppercase letters (A through
H
), representing the colors of the desired result of the shuffling of
S1
and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though
N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1
(−1) for the number of shuffle operations.

Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output
1 2
2 -1

Source
Greater New York 2006

模拟一下洗牌的过程,用map<string,bool>vis 记录状态。
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#include <cstring>
#include <map>
int main()
{
int t;
scanf("%d",&t);
int num=0;
int i,j,k;
while(t--)
{
num++;
int c;
cin>>c;
char s1[1005];
char s2[1005];
char s3[2010];
char s4[4020];
cin>>s1>>s2>>s3;
map<string,bool>vis;
vis.clear();
vis[s3]=1;
int step=0;
while(1)
{
int len=0;
for(i=0; i<c; i++)
{
s4[len++]=s2[i];
s4[len++]=s1[i];
}
s4[len]='\0';
step++;
if(!strcmp(s4,s3))
{
cout<<num<<" "<<step<<endl;
break;
}
if(vis[s4]&&strcmp(s4,s3))
{
cout<<num<<" "<<-1<<endl;
break;
}
vis[s4]=1;
for(i=0; i<c; i++)
s1[i]=s4[i];
s1[i]='\0';
for(j=0; i<c*2; j++,i++)
s2[j]=s4[i];
s2[j]='\0';
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM算法