您的位置:首页 > 产品设计 > UI/UE

hdoj Proving Equivalences 2767 (强连通分量 最少添加几条边使图强连通)

2015-10-19 22:57 387 查看

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4329    Accepted Submission(s): 1537


[align=left]Problem Description[/align]
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.

2. Ax = b has exactly one solution for every n × 1 matrix b.

3. Ax = b is consistent for every n × 1 matrix b.

4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the
four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a
lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

[align=left]Input[/align]
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.

* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

[align=left]Output[/align]
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

[align=left]Sample Input[/align]

2
4 0
3 2
1 2
1 3

[align=left]Sample Output[/align]

4
2题意:有n个命题,m个证明,每个证明有两个数(a,b),表示a命题可以推出b命题,问最少还要添加几个证明,使得n个命题可以互推。思路:转换成n个点,m条边问最少添加几条边使图强连通。
//因为数据太大,不能用连接表(会爆站)。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
#include<stack>
#define N 20010
using namespace std;
vector<int>g
;
int low
;
int dfn
,dfs_clock;
int sccon
,scc_cnt;
bool instack
;
stack<int>s;
int n,m;
void tarjan(int u,int fa)
{
int v;
low[u]=dfn[u]=++dfs_clock;
s.push(u);
instack[u]=true;
for(int i=0;i<g[u].size();i++)
{
v=g[u][i];
if(!dfn[v])
{
tarjan(v,u);
low[u]=min(low[u],low[v]);
}
else if(instack[v])
low[u]=min(low[u],dfn[v]);
}
if(low[u]==dfn[u])
{
scc_cnt++;
while(1)
{
v=s.top();
s.pop();
instack[v]=false;
sccon[v]=scc_cnt;
if(v==u)
break;
}
}
}
void find(int l,int r)
{
memset(low,0,sizeof(low));
memset(dfn,0,sizeof(dfn));
memset(sccon,0,sizeof(sccon));
memset(instack,false,sizeof(instack));
dfs_clock=scc_cnt=0;
for(int i=l;i<=r;i++)
if(!dfn[i])
tarjan(i,-1);
}
int in
,out
;
void soudian()
{
int i,j;
for(i=1;i<=scc_cnt;i++)
in[i]=out[i]=0;
for(i=1;i<=n;i++)
{
for(j=0;j<g[i].size();j++)
{
int u=sccon[i];
int v=sccon[g[i][j]];
if(u!=v)
{
out[u]++;
in[v]++;
}
}
}
}
void solve()
{
find(1,n);
soudian();
if(scc_cnt==1)
{
printf("0\n");
return ;
}
int sumin=0,sumout=0;
for(int i=1;i<=scc_cnt;i++)
{
if(in[i]==0)
sumin++;
if(out[i]==0)
sumout++;
}
printf("%d\n",max(sumin,sumout));
}
int main()
{
int t,x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
g[i].clear();
while(m--)
{
scanf("%d%d",&x,&y);
g[x].push_back(y);
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: