您的位置:首页 > 运维架构

1688: [Usaco2005 Open]Disease Manangement 疾病管理

2015-10-16 22:48 429 查看

1688: [Usaco2005 Open]Disease Manangement 疾病管理

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 456  Solved: 305

[Submit][Status][Discuss]

Description

Alas! A set of D (1 <= D <= 15) diseases (numbered 1..D) is running through the farm. Farmer John would like to milk as many of his N (1 <= N <= 1,000) cows as possible.
If the milked cows carry more than K (1 <= K <= D) different diseases among them, then the milk will be too contaminated and will have to be discarded in its entirety. Please help determine the largest number of cows FJ can milk without having to discard the
milk.

Input

* Line 1: Three space-separated integers: N, D, and K * Lines 2..N+1: Line i+1 describes the diseases of cow i with a list of 1 or more space-separated integers. The first
integer, d_i, is the count of cow i's diseases; the next d_i integers enumerate the actual diseases. Of course, the list is empty if d_i is 0. 有N头牛,它们可能患有D种病,现在从这些牛中选出若干头来,但选出来的牛患病的集合中不过超过K种病.

Output

* Line 1: M, the maximum number of cows which can be milked.

Sample Input

6 3 2

0---------第一头牛患0种病

1 1------第二头牛患一种病,为第一种病.

1 2

1 3

2 2 1

2 2 1

Sample Output

5

OUTPUT DETAILS:

If FJ milks cows 1, 2, 3, 5, and 6, then the milk will have only two

diseases (#1 and #2), which is no greater than K (2).

HINT

Source

我会说我今天只A了这一题吗。。。。
我会说我今天做了三题一题WA一题RT吗。。。
果然月考减智商!!!!
不过还好状压dp一眼就看出来了。。。
用二进制的|运算符来搞集合!!!
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<queue>
#include<stack>
#include<vector>
#include<cstdlib>
#include<map>
#include<cmath>
using namespace std;

const int maxn = (1 << 16) + 10;

int f[maxn][2],n,i,j,cow[1010],m,k,num[maxn];

int main()
{
#ifndef ONLINE_JUDGE
#ifndef YZY
freopen(".in","r",stdin);
freopen(".out","w",stdout);
#else
freopen("yzy.txt","r",stdin);
#endif
#endif
cin >> n >> m >> k;
for (i = 1; i <= n; i++)
{
scanf("%d",&j);
while (j--)
{
int x;
scanf("%d",&x);
cow [i] += 1 << (x-1);
}
}
for (i = 1; i < 1 << 16; i++)
for (j = i; j; j >>= 1) num[i] += j & 1;
for (int l = 1; l <= n; l++)
{
for (i = 1; i < 1 << 16; i++)
if (num[i | cow[l]] <= k)
f[i | cow[l]][1] = max(f[i | cow[l]][1],f[i][0] + 1);
for (i = 1; i < 1 << 16; i++) f[i][0] = max(f[i][1],f[i][0]),f[i][1] = 0;
}
int ans = 0;
for (i = 1; i < 1 << 16; i++)
ans = max(ans,f[i][0]);
cout << ans;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: