您的位置:首页 > 其它

HDU - 2612 Find a way(15.10.10 搜索专题)bfs

2015-10-11 22:58 459 查看
Find a way

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u
Submit Status

Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 

Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 

Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

 

Input

The input contains multiple test cases. 

Each test case include, first two integers n, m. (2<=n,m<=200). 

Next n lines, each line included m character. 

‘Y’ express yifenfei initial position. 

‘M’    express Merceki initial position. 

‘#’ forbid road; 

‘.’ Road. 

‘@’ KCF 

 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

 

Sample Output

66
88
66

 

题意:两个人约KFC,要到找到一个KFC到两人的距离和最短,输出最短距离乘以11。
思路:两个bfs求出两个人到图上每个KFC的最短距离,在枚举每个KFC求和距离最小的一个。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
using namespace std;

#define min(a,b) a<b?a:b

const int dirx[4] = { 0, 0, 1, -1 };
const int diry[4] = { 1, -1, 0, 0 };

char map[210][210];
bool vis[210][210];
int disY[210][210];
int disM[210][210];
int n, m;

struct Point
{
int x, y;
Point(int xx, int yy) :x(xx), y(yy){}
Point(){};
};

queue<Point>que;

void bfsY(int x, int y)
{
while (!que.empty())
que.pop();
memset(vis, false, sizeof(vis));
memset(disY, -1, sizeof(disY));

que.push(Point(x, y));
vis[x][y] = true;
disY[x][y] = 0;

while (!que.empty())
{
Point loc = que.front();
que.pop();

for (int i = 0; i < 4; i++)
{
int xx = loc.x + dirx[i];
int yy = loc.y + diry[i];

if (xx >= 0 && xx < n && yy >= 0 && yy < m && map[xx][yy] != '#' && !vis[xx][yy])
{
disY[xx][yy] = disY[loc.x][loc.y] + 1;
vis[xx][yy] = true;
que.push(Point(xx, yy));
}
}
}
}

void bfsM(int x, int y)
{
while (!que.empty())
que.pop();
memset(vis, false, sizeof(vis));
memset(disM, -1, sizeof(disM));

que.push(Point(x, y));
vis[x][y] = true;
disM[x][y] = 0;

while (!que.empty())
{
Point loc = que.front();
que.pop();

for (int i = 0; i < 4; i++)
{
int xx = loc.x + dirx[i];
int yy = loc.y + diry[i];

if (xx >= 0 && xx < n && yy >= 0 && yy < m && map[xx][yy] != '#' && !vis[xx][yy])
{
disM[xx][yy] = disM[loc.x][loc.y] + 1;
vis[xx][yy] = true;
que.push(Point(xx, yy));
}
}
}
}

int main()
{
while (scanf("%d%d", &n, &m) != EOF)
{
for (int i = 0; i < n; i++)
scanf("%s", map[i]);

Point posY, posM;

for (int i = 0; i < n; i++)
for (int j = 0; j < m; j++)
{
if (map[i][j] == 'Y')
{
posY.x = i;
posY.y = j;
}
else if (map[i][j] == 'M')
{
posM.x = i;
posM.y = j;
}
}

bfsY(posY.x, posY.y);
bfsM(posM.x, posM.y);

int ans = 1e9;
for (int i = 0; i < n; i++)
for (int j = 0; j < m; j++)
if (map[i][j] == '@' && disY[i][j]!=-1 &&disM[i][j]!=-1)
{
ans = min(ans, disY[i][j] + disM[i][j]);
}

printf("%d\n", ans * 11);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 搜索 bfs