您的位置:首页 > 其它

hdoj MZL's xor 5344 (异或)

2015-10-11 14:42 218 查看

MZL's xor

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 904 Accepted Submission(s): 586


[align=left]Problem Description[/align]
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)

The xor of an array B is defined as B1
xor B2...xor
Bn

[align=left]Input[/align]
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.

Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai−1∗m+z)
mod
l
1≤m,z,l≤5∗105,n=5∗105

[align=left]Output[/align]
For every test.print the answer.

[align=left]Sample Input[/align]

2
3 5 5 7
6 8 8 9

[align=left]Sample Output[/align]

14
16
#include<stdio.h>
#include<string.h>
#define N 500010
int a[5*N];
int main()
{
int t;
int n,m,z,l;
int i,j;
int sum;
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
scanf("%d%d%d%d",&n,&m,&z,&l);
for(i=2;i<=n;i++)
{
a[i]=((long long)a[i-1]*m+z)%l;
}
sum=0;
for(i=1;i<=n;i++)
sum=sum^(a[i]*2);
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: