您的位置:首页 > 其它

poj 1451 T9 【字典树 + DFS 模拟智能英语输入法】

2015-10-10 17:31 375 查看
T9

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3560 Accepted: 1280
Description

Background 

A while ago it was quite cumbersome to create a message for the Short Message Service (SMS) on a mobile phone. This was because you only have nine keys and the alphabet has more than nine letters, so most characters could only be entered by pressing one key
several times. For example, if you wanted to type "hello" you had to press key 4 twice, key 3 twice, key 5 three times, again key 5 three times, and finally key 6 three times. This procedure is very tedious and keeps many people from using the Short Message
Service. 

This led manufacturers of mobile phones to try and find an easier way to enter text on a mobile phone. The solution they developed is called T9 text input. The "9" in the name means that you can enter almost arbitrary words with just nine keys and without pressing
them more than once per character. The idea of the solution is that you simply start typing the keys without repetition, and the software uses a built-in dictionary to look for the "most probable" word matching the input. For example, to enter "hello" you
simply press keys 4, 3, 5, 5, and 6 once. Of course, this could also be the input for the word "gdjjm", but since this is no sensible English word, it can safely be ignored. By ruling out all other "improbable" solutions and only taking proper English words
into account, this method can speed up writing of short messages considerably. Of course, if the word is not in the dictionary (like a name) then it has to be typed in manually using key repetition again. 


 

Figure 8: The Number-keys of a mobile phone.

More precisely, with every character typed, the phone will show the most probable combination of characters it has found up to that point. Let us assume that the phone knows about the words "idea" and "hello", with "idea" occurring more often. Pressing the
keys 4, 3, 5, 5, and 6, one after the other, the phone offers you "i", "id", then switches to "hel", "hell", and finally shows "hello". 

Problem 

Write an implementation of the T9 text input which offers the most probable character combination after every keystroke. The probability of a character combination is defined to be the sum of the probabilities of all words in the dictionary that begin with
this character combination. For example, if the dictionary contains three words "hell", "hello", and "hellfire", the probability of the character combination "hell" is the sum of the probabilities of these words. If some combinations have the same probability,
your program is to select the first one in alphabetic order. The user should also be able to type the beginning of words. For example, if the word "hello" is in the dictionary, the user can also enter the word "he" by pressing the keys 4 and 3 even if this
word is not listed in the dictionary.
Input

The first line contains the number of scenarios. 

Each scenario begins with a line containing the number w of distinct words in the dictionary (0<=w<=1000). These words are iven in the next w lines in ascending alphabetic order. Every line starts with the word which is a sequence of lowercase letters from
the alphabet without whitespace, followed by a space and an integer p, 1<=p<=100, representing the probability of that word. No word will contain more than 100 letters. 

Following the dictionary, there is a line containing a single integer m. Next follow m lines, each consisting of a sequence of at most 100 decimal digits 2�, followed by a single 1 meaning "next word".
Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. 

For every number sequence s of the scenario, print one line for every keystroke stored in s, except for the 1 at the end. In this line, print the most probable word prefix defined by the probabilities in the dictionary and the T9 selection rules explained above.
Whenever none of the words in the dictionary match the given number sequence, print "MANUALLY" instead of a prefix. 

Terminate the output for every number sequence with a blank line, and print an additional blank line at the end of every scenario.
Sample Input
2
5
hell 3
hello 4
idea 8
next 8
super 3
2
435561
43321
7
another 5
contest 6
follow 3
give 13
integer 6
new 14
program 4
5
77647261
6391
4681
26684371
77771

Sample Output
Scenario #1:
i
id
hel
hell
hello

i
id
ide
idea

Scenario #2:
p
pr
pro
prog
progr
progra
program

n
ne
new

g
in
int

c
co
con
cont
anoth
anothe
another

p
pr
MANUALLY
MANUALLY
提示:按手机键2,手机可能会出现a或b或c。当然,这取决于 —— 手机记忆里按键2输入a或b或c的次数。

题意:手机上记录有n个单词,已经给出每个单词出现在手机里面的概率p。现在有一串数字(以1结束),表示在手机上按键的顺序。现在让你模拟输出每次按键后手机所出现的单词信息。

思路:建好字典树并记录每个节点的概率值,当然这个概率是可以叠加的。
对于一串长度为len的数字(包括1),遍历长度1——(len-1)。对每次的遍历值i,在树上跑一次DFS,根据i个按键信息找到长度为i的串中具有最大概率的串。

AC代码:#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 100000+10
using namespace std;
char key[8][5] = {{"abc"}, {"def"}, {"ghi"}, {"jkl"}, {"mno"}, {"pqrs"}, {"tuv"}, {"wxyz"}};
int next[MAXN][30], time[MAXN];
int L, root;
int newnode()
{
for(int i = 0; i < 26; i++)
next[L][i] = -1;
time[L++] = 0;
return L-1;
}
void init()
{
L = 0;
root = newnode();
}
void Insert(char *s, int num)
{
int len = strlen(s);
int now = root;
for(int i = 0; i < len; i++)
{
if(next[now][s[i]-'a'] == -1)
next[now][s[i]-'a'] = newnode();
now = next[now][s[i]-'a'];
time[now] += num;
}
}
char ans[1010];
int Mp;//记录节点最大概率值
char str[1010], temp[1010];
void DFS(int goal, int now, int ROOT)
{
if(now == goal + 1)
{
if(time[ROOT] > Mp)
{
Mp = time[ROOT];
strcpy(ans, temp);
}
}
else
{
int num = str[now] - '0' - 2;//当前按键 可能出现的字符串下标
int len = strlen(key[num]);//可能出现的字符个数
for(int i = 0; i < len; i++)//遍历
{
int v = key[num][i] - 'a';
if(next[ROOT][v] == -1) continue;
temp[now] = key[num][i];
DFS(goal, now+1, next[ROOT][v]);
}
}
}
int main()
{
int t, k = 1;
int n, m;
scanf("%d", &t);
while(t--)
{
scanf("%d", &n);
init(); int num;
for(int i = 0; i < n; i++)
scanf("%s%d", str, &num), Insert(str, num);
scanf("%d", &m);
printf("Scenario #%d:\n", k++);
while(m--)
{
scanf("%s", str);
int len = strlen(str);
for(int i = 0; i < len-1; i++)
{
memset(temp, 0, sizeof(temp));
Mp = 0;//最大概率记录
DFS(i, 0, root);
if(Mp == 0)
printf("MANUALLY\n");
else
printf("%s\n", ans);
}
printf("\n");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: