您的位置:首页 > 其它

ZOJ-3633-Alice's present

2015-10-08 13:54 351 查看
Description

As a doll master, Alice owns a wide range of dolls, and each of them has a number tip on it's back, the tip can be treated as a positive integer. (the number can be repeated). One day, Alice hears that her best friend Marisa's birthday is coming , so she
decides to sent Marisa some dolls for present. Alice puts her dolls in a row and marks them from 1 to
n. Each time Alice chooses an interval from i to j in the sequence ( include
i and j ) , and then checks the number tips on dolls in the interval from right to left. If any number appears more than once , Alice will treat this interval as unsuitable. Otherwise, this interval will be treated as suitable.

This work is so boring and it will waste Alice a lot of time. So Alice asks you for help .

Input

There are multiple test cases. For each test case:

The first line contains an integer n ( 3≤ n ≤ 500,000) ,indicate the number of dolls which Alice owns.

The second line contains n positive integers , decribe the number tips on dolls. All of them are less than 2^31-1. The third line contains an interger
m ( 1 ≤ m ≤ 50,000 ),indicate how many intervals Alice will query. Then followed by m lines, each line contains two integer
u, v ( 1≤ u< v≤ n ),indicate the left endpoint and right endpoint of the interval. Process to the end of input.

Output

For each test case:

For each query, If this interval is suitable , print one line "OK". Otherwise, print one line ,the integer which appears more than once first.

Print an blank line after each case.

Sample Input

5
1 2 3 1 2
3
1 4
1 5
3 5
6
1 2 3 3 2 1
4
1 4
2 5
3 6
4 6


Sample Output

1
2
OK

3
3
3
OK

Hint

Alice will check each interval from right to left, don't make mistakes.

简单的数学题
#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
using namespace std;
int main()
{
int n;
int arr[500005];
map<int,int> m1;
while(cin>>n)
{
for(int i=0;i<n;++i)
cin>>arr[i];
int m;
cin>>m;
// cout<<m<<endl;
for(int i=0;i<m;++i)
{
// cout<<"sdf"<<endl;
int l,r,res=-1;
cin>>l>>r;
m1.clear();
for(int i=r-1;i>=l-1;--i)
{
m1[arr[i]]++;
if(m1[arr[i]]>1)
{
res=arr[i];
break;
}
}
// cout<<res<<endl;
if(res==-1)
cout<<"OK"<<endl;
else
cout<<res<<endl;
}
cout<<"\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: