您的位置:首页 > 其它

UVA_1592: Database

2015-10-05 21:21 441 查看

Description

Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns. There are different
normal forms that database may adhere to. Normal forms are designed to minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author,
and author's email. If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter's Normal Form (PNF) if and only if there is
no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.

How to compete in ACM ICPCPeterpeter@neerc.ifmo.ru
How to win ACM ICPCMichaelmichael@neerc.ifmo.ru
Notes from ACM ICPC championMichaelmichael@neerc.ifmo.ru
The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables -- one containing book name and author id, and the other containing
book id, author name, and author email, then both resulting tables will be in PNF.




Given
a table your task is to figure out whether it is in PNF or not.

Input

Input contains several datasets. The first line of each dataset contains two integer numbers
n and m (1

n

10000,
1

m

10),
the number of rows and columns in the table. The following n lines contain table rows. Each row has
m column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and
trailing spaces. Each row has at most 80 characters (including separating commas).

Output

For each dataset, if the table is in PNF write to the output file a single word ``YES" (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word ``NO" (without quotes). On
the second line write two integer row numbers r1 and
r2 (1

r1,
r2

n,
r1

r2), on the third line write two integer column numbers
c1 and c2 (1

c1,
c2

m,
c1

c2), so that values in columns
c1 and c2 are the same in rows
r1 and r2.

Sample Input

3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru


Sample Output

NO
2 3
2 3
YES


分析:首先是数据处理,可以把所有字符串读取存储在vector中,然后用map映射row的值,同时对字符串进行编号(唯一),读取完后进行主循环;依次扫描每行,一次只选择一组串c1和c2,即枚举列,每次碰到新的行,把c1和c2对应的字符串的编号取出来作为二元组存到map中,首先判断是否已经存在,如果存在则返回行号,否则存进去继续扫描。

#include <iostream>
#include <map>
#include <vector>
#include <string>
#include <cstdio>

using namespace std;

map<int,int> pnf; //PNF二维组

map<string,int> IDcache; //存储字符串对应的ID
vector<string> Strcache; //生成字符串判定ID

map<string,int> Strrow; //存放字符串对应行号
vector<string> Strbuf; //存放所有字符串

int uniqueID(string s)
{
if(IDcache.count(s)) return IDcache[s];
Strcache.push_back(s);
return IDcache[s] = Strcache.size()-1;
}

void storeStr(string s, int row)
{
Strbuf.push_back(s);
Strrow[s] = row;
}

int pnfID(int c1,int c2)
{
if(pnf.count(c1) && pnf[c1]==c2){
return Strrow[Strcache[c1]];
}
pnf[c1]=c2;
return -1;
}

int main()
{
int row,col;
string s;
char temp[100];
while(~scanf("%d%d",&row,&col))
{
getchar();
IDcache.clear();Strcache.clear();Strrow.clear();Strbuf.clear();
for(int i=0; i<row; i++)
{
int index = 0; int c;
for(int j=0; j<col; j++)
{
index = 0;
while((c=getchar())&&c!=','&&c!='\n'&&c!=EOF)temp[index++]=c;
temp[index] = 0;
s = temp;
storeStr(s,i);
uniqueID(s);
}
}

int c1,c2;
for(c1=0; c1<col-1; c1++)
{
for(c2=c1+1; c2<col; c2++)
{
pnf.clear();
for(int i=0; i<row; i++)
{
int id1 = i*col + c1; int id2 = i*col + c2;
int row1 = IDcache[Strbuf[id1]]; int row2 = IDcache[Strbuf[id2]];
int r = pnfID(row1,row2);
if(r>=0){
printf("NO\n");
printf("%d %d\n%d %d\n",r,i+1,c1+1,c2+1);
goto s5;
}
}
}
}
printf("YES\n");
s5:;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: