您的位置:首页 > 产品设计 > UI/UE

POJ 1503 Integer Inquiry 美丽的大整数相加 + 测试数据

2015-10-01 20:27 435 查看

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy
were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

Sample Output

370370367037037036703703703670

题意:计算给定的n传输的和

思路:字符串相加;

WA点:1.就是单纯的0结束,有可能出现前导0,2.就是进位问题,3速出的时候的前导0

AC代码:

#include <iostream>

#include <cstdio>

#include <cstring>

using namespace std;

char s[1005];

char sum[1005];

void jia(){

int lensum = strlen(sum) - 1;

int lens = strlen(s) - 1;

int a = 0;

int t = 0;

char ss[1005];

memset(ss,0,sizeof(ss));

while(lensum >= 0 && lens >= 0 ){

a += sum[lensum--] - '0' + s[lens--] - '0';

if(a > 9){

ss[t++] = a - 10 + '0';

a = 1;

}

else{

ss[t++] += a + '0';

a = 0;

}

}//对应位相加

while(lensum >= 0 && lens < 0){

a += sum[lensum--] - '0';

if(a > 9){

ss[t++] = a - 10 + '0';

a = 1;

}

else{

ss[t++] += a + '0';

a = 0;

}

} //出现前面一直是9

while(lens >= 0 && lens < 0){

a += sum[lensum--] - '0';

if(a > 9){

ss[t++] = a - 10 + '0';

a = 1;

}

else{

ss[t++] += a + '0';

a = 0;

}

}//同上

if(lensum < 0 && lens < 0 && a == 1){

ss[t++] = '1';

}//就是最高位 的 和 有进位

ss[t] = '\0';

int ttt = 0;

for(int ok = t - 1;ok >= 0;ok--){

sum[ttt++] = ss[ok];

}

sum[ttt] = '\0';

}

int main(){

memset(sum,0,sizeof(sum));

int ok = 1;

while(scanf("%s",s) != EOF){

if( s[0] != '0' && strlen(s) == 1){

break;

}//结束的标志

if(ok){

for(int i = 0;i < strlen(s);i++){

sum[i] = s[i];

}

ok = 0;

}

else

jia();

}

int i;

for( i = 0;i < strlen(sum);i++){

if(sum[i] != '0'){

break;

}

}

for(;i < strlen(sum);i++){

printf("%c",sum[i]);//排除前导0

}

if(i < strlen(sum)){

printf("0");

}//0+0

return 0;

}

测试数据:

987654321 + 123456789

0 不输出
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: