您的位置:首页 > 其它

PAT(甲级)1089

2015-09-29 11:05 169 查看


1089. Insert or Merge (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts
it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist
remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed
that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed
that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6


#include <iostream>
#include <string.h>
#define MAX 101

using namespace std;

int a[MAX],b[MAX],c[MAX];

bool equal_array(int a[],int b[],int n)
{
int i=0;
for(i=0;i<n;i++)
if(a[i] != b[i])
return false;
return true;
}

void print_array(int a[],int n){
int i;
for(i=0;i<n-1;i++)
cout <<a[i] <<' ';
cout <<a[n-1] <<endl;
}

void Insertion(int a[],int b[],int c[],int n,bool &found){
memcpy(c,a,sizeof(int)*n);
int i,j,k;
for(i=1;i<n;i++){
int tmp = c[i];
for(j=i-1;j>=0;j--){
if(tmp <c[j]){
c[j+1] = c[j];
}else{
break;
}
}
c[j+1] = tmp;
if(found){
cout <<"Insertion Sort" <<endl;
print_array(c,n);
return;
}
if(equal_array(c,b,n))
found =true;
}

}
/////////////////////////////////////////////////////////////////////
void merge(int a[],int pos,int len1,int len2){
int i,j,k;
int *p=new int[len1+len2];
i=j=k=0;
while(i<len1&&j<len2){
if(a[pos+i] < a[pos+len1+j]){
p[k] = a[pos+i];
i++;
}else{
p[k]= a[pos+len1+j];
j++;
}
k++;
}
for(;i<len1;i++){
p[k] = a[pos+i];
k++;
}

for(;j<len2;j++){
p[k] = a[pos+len1+j];
k++;
}
for(i=0;i<len1+len2;i++)
a[pos+i] = p[i];
delete []p;
}

void merge_sort1(int a[],int len,int n){
int i,count,pos=0;
count = n/(2*len);  //pairs of arrays
for(i=1;i<=count;i++){
merge(a,pos,len,len);
pos +=2*len;
}
int remain = n -pos;
if(remain >len)
merge(a,pos,len,remain-len);
}

void Merge_sort(int a[],int b[],int n){
int i,j,k;
bool found =false;
int len =1;
while(len <n){
merge_sort1(a,len,n);
if(found){
cout <<"Merge Sort" <<endl;
print_array(a,n);
break;
}
if(equal_array(a,b,n))
found =true;
len = len*2;
}
}

int main()
{
int n,i=0;
bool found =false;
cin >>n;
for(i=0;i<n;i++)
cin >>a[i];
for(i=0;i<n;i++)
cin >>b[i];
Insertion(a,b,c, n,found);
if(!found)
Merge_sort(a,b,n);
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: