您的位置:首页 > 其它

zoj 5518 异或

2015-09-28 18:19 211 查看
题目链接:链接
Team Formation

Time Limit: 3 Seconds
Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from
N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level
A and B form a team, the skill level of the team will be
A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e.
A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains
N positive integers separated by spaces. The ith integer denotes the skill level of
ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

思路:两个数异或,较小的数的最高位(i位)的1,对应在较大数的相同位置(i位), 若大数的i位为0,则两个数的异或值大于较大的数。故 对所有数进行排序,计算出每个位置上 最高位为1的数的个数,
code:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int bit[50],a[100100];
int sol(int m)
{
    int pos=0,ans=0;
    while(m>1)
    {
        if(m%2==0)
            ans+=bit[pos];//<span style="font-size:18px;">计算出每个位置上 最高位为1的数的个数,</span>
        pos++;
        m/=2;
    }
    bit[pos]++;
    return ans;
}
int main()
{
    int cas,n,i,j,ans;
    scanf("%d",&cas);
    while(cas--)
    {
        memset(bit,0,sizeof(bit));
        ans=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        for(i=0;i<n;i++)
            ans+=sol(a[i]);
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: