您的位置:首页 > 其它

hdu5477 A Sweet Journey(简单模拟)

2015-09-26 19:38 309 查看
Link:http://acm.hdu.edu.cn/showproblem.php?pid=5477


A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 117 Accepted Submission(s): 60



Problem Description

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will
regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)





Input

In the first line there is an integer t (1≤t≤50),
indicating the number of test cases.

For each test case:

The first line contains four integers, n, A, B, L.

Next n lines, each line contains two integers: Li,Ri,
which represents the interval [Li,Ri] is
swamp.

1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.

Make sure intervals are not overlapped which means Ri<Li+1 for
each i (1≤i<n).

Others are all flats except the swamps.



Output

For each text case:

Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.



Sample Input

1
2 2 2 5
1 2
3 4




Sample Output

Case #1: 0




Source

2015 ACM/ICPC Asia Regional Shanghai Online



AC code:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<stack>
#include<vector>
#define LL long long
#define MAXN 1000010
using namespace std;
const  int N=20;
struct node{
	int l;
	int r;
	bool operator < (const node &b)const
	{
		return l<b.l;
	}
}road[MAXN];
LL ans,c;
int main()
{
//	freopen("D:\\in.txt","r",stdin);
	int T,i,j,cas,n,a,b,len,temp;
	scanf("%d",&T);
	for(cas=1;cas<=T;cas++)
	{
		scanf("%d%d%d%d",&n,&a,&b,&len);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&road[i].l,&road[i].r);
		}
		ans=0;
		temp=0;
		c=0;
		for(i=1;i<=n;i++)
		{
			c+=b*(road[i].l-temp);
			if(c < (road[i].r-road[i].l)*a)
			{
				ans+=((road[i].r-road[i].l)*a-c);
				c=0;
			}
			else
			{
				c-=(road[i].r-road[i].l)*a;
			}
			temp=road[i].r;
		}
		printf("Case #%d: %I64d\n",cas,ans);
	}
  	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: