您的位置:首页 > 产品设计 > UI/UE

hdu1159 Common Subsequence (最长公共子串)

2015-09-24 21:47 585 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 29176 Accepted Submission(s): 13084



Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab
programming contest 
abcd mnp


Sample Output
4
2
0


Source
Southeastern Europe 2003

题意:求两个串的最长公共串。
分析:经典LCS,详解见代码。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

string s1,s2;
int dp[1010][1010];//s1串前i个字符和s2串前j个字符的最长公共子串

int main ()
{
    while (cin>>s1>>s2)
    {
        CL(dp);
        for (int i=1; i<=s1.length(); i++)//i指向串s1
        {
            for (int j=1; j<=s2.length(); j++)//j指向串s2
            {
                if (s1[i-1] == s2[j-1])//如果当前字符相同,i,j均向右移一位,当前最大长度就为前一个情况加1
                    dp[i][j] = dp[i-1][j-1]+1;
                else//否则,要么i向右移一位,要么j向右移一位,长度不变
                    dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
            }
        }
        cout<<dp[s1.length()][s2.length()]<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: