您的位置:首页 > 其它

poj 2159 Ancient Cipher(水)

2015-09-23 19:33 323 查看
Ancient Cipher

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 30695Accepted: 10023
Description

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from 'A' to 'Y' to the next ones in the alphabet, and changes 'Z' to 'A', to the message "VICTORIOUS" one gets the message "WJDUPSJPVT".
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation <2, 1, 5, 4, 3, 7, 6, 10, 9, 8> to the message "VICTORIOUS" one gets the message "IVOTCIRSUO".
It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message "VICTORIOUS" with the combination of the ciphers described above one gets the message "JWPUDJSTVP".
Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.
Input

Input contains two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet.
The lengths of both lines of the input are equal and do not exceed 100.
Output

Output "YES" if the message on the first line of the input file could be the result of encrypting the message on the second line, or "NO" in the other case.
Sample Input

JWPUDJSTVP
VICTORIOUS

Sample Output

YES

由于顺序是可以改变的.
所以考虑是否可以映射.只要存在字母对应出现的次数都相同.那么就可以通过映射得到.
具体是开一个数组记录每个字母出现的次数...
然后sort


/*************************************************************************
> File Name: code/poj/2159.cpp
> Author: 111qqz
> Email: rkz2013@126.com
> Created Time: 2015年09月23日 星期三 19时04分34秒
************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#include<cctype>
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define ms(a,x) memset(a,x,sizeof(a))
#define lr dying111qqz
using namespace std;
#define For(i, n) for (int i=0;i<int(n);++i)
typedef long long LL;
typedef double DB;
const int inf = 0x3f3f3f3f;
const int N=30;
string st1,st2;
int len;
int a
,b
;

bool cmp( int a,int b)
{
if (a>b) return true;
return false;
}
int main()
{
#ifndef  ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
ms(a,0);
ms(b,0);
cin>>st1>>st2;
len = st1.length();
// cout<<st1<<endl<<st2<<endl;
for ( int i = 0 ; i < len ; i ++)
{
int tmp = st1[i]-'A';
a[tmp]++;
tmp = st2[i]-'A';
b[tmp]++;
}

sort(a,a+26,cmp);
sort(b,b+26,cmp);
//  for ( int i = 0 ; i < 26 ; i++) cout<<"a[i]:"<<a[i]<<" b[i]"<<b[i]<<endl;

bool flag = true;
for ( int i = 0 ; i < 26 ; i++)
{
if (a[i]!=b[i])
{
flag = false;
break;
}
}
if (flag)
{
puts("YES");
}
else
{
puts("NO");
}

#ifndef ONLINE_JUDGE
fclose(stdin);
#endif
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: