您的位置:首页 > 编程语言

PAT(甲级)1003

2015-09-23 15:55 274 查看


1003. Emergency (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked
on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in
and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

#include <iostream>

const int SIZE =505;

int Graph[SIZE][SIZE];
//int dis[SIZE];
//////////////////////////////////////////////////////////////
//can try another method:
//1.use original dijkstr algorithms
//2. use DFS to find more path
//
//
////////////////////////////////////////////////////////////////
struct Node{
Node(){
distance = -1;
count = 0;
number = 0;
maxnumber =0;
visited = false;
}
unsigned int distance;
unsigned int count;
unsigned int number;
unsigned int maxnumber;
bool visited;
};

Node Nodelist[SIZE];
using namespace std;

void Dijkstra(const int &source,const int &limit){
Nodelist[source].count = 1;
Nodelist[source].distance = 0;
int i=0;
while(i++ < limit){
unsigned int min =-1;
int index =0;
for(int j=0;j<limit;j++){ //find shortest edge
if(!Nodelist[j].visited &&Nodelist[j].distance < min){
min = Nodelist[j].distance;
index = j;
}
}
Nodelist[index].visited = true;
for(int j=0;j<limit;j++){ //update shortest distance
if(Graph[index][j] && Nodelist[j].distance > Nodelist[index].distance + Graph[index][j]){ //replace existing edge
Nodelist[j].distance = Nodelist[index].distance + Graph[index][j];
Nodelist[j].count = Nodelist[index].count;
Nodelist[j].maxnumber = Nodelist[index].maxnumber + Nodelist[j].number;
}else if(Graph[index][j] && Nodelist[j].distance == Nodelist[index].distance + Graph[index][j]){
Nodelist[j].count += Nodelist[index].count;
Nodelist[j].maxnumber = Nodelist[j].maxnumber > (Nodelist[index].maxnumber + Nodelist[j].number) ? Nodelist[j].maxnumber: (Nodelist[index].maxnumber + Nodelist[j].number);
}
}
}
}

int main()
{
int N,M,source,destination,weight;
int c1,c2;
// freopen("test.txt","r",stdin);
scanf("%d%d%d%d",&N,&M,&source,&destination);
for(int i=0;i<N;i++)
for(int j=0;j<N;j++)
Graph[i][j] = 0;

for(int i=0;i<N;i++){
scanf("%d",&weight);
Nodelist[i].number = weight;
Nodelist[i].maxnumber = weight;
}

for(int i=0;i<M;i++){
scanf("%d%d%d",&c1,&c2,&weight);
Graph[c1][c2] = weight;
Graph[c2][c1] = weight;
}

Dijkstra(source,N);

printf("%d %d\n",Nodelist[destination].count,Nodelist[destination].maxnumber);
// fclose(stdin);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  代码 PAT