您的位置:首页 > 其它

POJ 3660 Cow Contest 最短路floyd

2015-09-22 21:39 246 查看
Cow Contest

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8551Accepted: 4802
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will
always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results
of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output
2


告诉两个牛实力的排序,排在前面的实力强,问有几头牛实力是可以确定的

floyd先求出整个的连通性,对于一头牛,如果实力比他强和比他弱的牛数目和等于n-1,那么这个牛的排名是可以确定的。

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
int mp[1009][1009];
int befor[1009];
int after[1009];

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(mp,0,sizeof mp);
        memset(befor,0,sizeof befor);
        memset(after,0,sizeof after);

        int a,b;

        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            mp[b][a]=1;
        }

        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    mp[i][j]=mp[i][j] | (mp[i][k]&mp[k][j]);
                }
            }
        }

        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                if(i==j) continue;
                if(mp[i][j])
                {
                    befor[i]++;
                    after[j]++;
                }
            }

        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(befor[i]+after[i]==n-1)
                ans++;
        }
        printf("%d\n",ans);
        
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: