您的位置:首页 > 其它

hdoj 1016 Prime Ring Problem【DFS】

2015-09-22 17:34 465 查看

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35069 Accepted Submission(s): 15523



[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



[align=left]Input[/align]
n (0 < n < 20).

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

[align=left]Sample Input[/align]

6
8


[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


[align=left]Source[/align]
Asia 1996, Shanghai (Mainland China)

题意:求出一个素数环,从1到n(输入的),相邻两个之和是素数并且第一个和最后一个的和也是素数,用深搜 递归处理
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int n;
int a[25], use[25];
int isprime(int x)
{
for(int i = 2; i < x/2; i++)
{
if(x%i==0)	return 0;
}
return 1;
}
void dfs(int c)
{
int i,j;
if(n==c&&isprime(1+a[n-1]))
{
for(i = 0; i < n; i++)
printf(i!=n-1?"%d ":"%d\n",a[i]);
}
else
{
for(i = 2; i <= n; i++)
{
if(!use[i]&&isprime(i+a[c-1]))
{
a[c] = i;
use[i] = 1;
dfs(c+1);
use[i] = 0;
}
}
}
}
int main()
{
int i,j,k,cas=1;
while(scanf("%d",&n)==1)
{
memset(use, 0, sizeof(use));
a[0] = 1;
printf("Case %d:\n",cas++);
dfs(1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: