您的位置:首页 > 其它

PAT(A)1002

2015-09-21 20:48 218 查看


1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


1002.多项式的A+B

这次,你需要计算出A和B两个多项式的和

输入:

每个输入文件包括一个测试用例。每个测试用例有两行,每一行包括一个多项式的信

息: K
N1 aN1 N2 aN2 ... NK aNK,K不为0, Ni
and aNi (i=1, 2, ..., K)分别为多项式的

指数和系数。且 给出的数字满足1
<= K <= 10,0 <= NK < ... < N2 < N1

<=1000

输出:

对于每一个测试用例,都应该在一行中输出A和B的和,且输出格式与输入格式与输入格式相同。注意末尾不应该有多余的空格,精确到小数点后一位。

这个并没有过。。不知道为啥。。先放着吧。。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAX = 1001;

struct node{
int n;
double a;
};
node NA[MAX];
node NB[MAX];

int main()
{
int K1, K2;
scanf("%d", &K1);
int exp = 0;
for(int i=0; i<K1; i++){
scanf("%d", &exp);
NA[exp].n = exp;
scanf("%lf", &NA[exp].a);
}
scanf("%d", &K2);
for(int i=0; i<K2; i++){
scanf("%d", &exp);
NB[exp].n = exp;
scanf("%lf", &NB[exp].a);
}
for(int i=0; i<1001; i++){
if(NA[i].a != 0){
NB[i].a += NA[i].a;
}
}
int cont = 0;
int MIN_id = 1000000;
for(int i=0; i<1001; i++){
if(NB[i].a != 0){
if(NB[i].n < MIN_id){
MIN_id = NB[i].n;
}
if(NB[i].a < 0){
if(NB[i].a > -0.05)
cont++;
}
else if(NB[i].a > 0){
if(NB[i].a > 0.05)
cont++;
}
}
}
if(cont == 0){
printf("0 0 0.0\n");
}
else{
printf("%d ", cont);
for(int i=1001; i>=0; i--){
if(NB[i].a != 0){
if(NB[i].a <=0.05 || NB[i].a <= -0.05)
continue;
else{
printf("%d %.1f", NB[i].n, NB[i].a);
if(i == MIN_id){
printf("\n");
break;
}
else
printf(" ");
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: