您的位置:首页 > 理论基础 > 计算机网络

2015北京网络赛 H题 Fractal 找规律

2015-09-20 20:18 375 查看

Fractal

Time Limit: 1 Sec

Memory Limit: 256 MB

题目连接

http://hihocoder.com/contest/acmicpc2015beijingonline/problem/8

Description

This is the logo of PKUACM 2016. More specifically, the logo is generated as follows:

1. Put four points A0(0,0), B0(0,1), C0(1,1), D0(1,0) on a cartesian coordinate system.

2. Link A0B0, B0C0, C0D0, D0A0 separately, forming square A0B0C0D0.

3. Assume we have already generated square AiBiCiDi, then square Ai+1Bi+1Ci+1Di+1 is generated by linking the midpoints of AiBi, BiCi, CiDi and DiAi successively.

4. Repeat step three 1000 times.

Now the designer decides to add a vertical line x=k to this logo( 0<= k < 0.5, and for k, there will be at most 8 digits after the decimal point). He wants to know the number of common points between the new line and the original logo.

Input

In the first line there’s an integer T( T < 10,000), indicating the number of test cases.

Then T lines follow, each describing a test case. Each line contains an float number k, meaning that you should calculate the number of common points between line x = k and the logo.

Output

For each test case, print a line containing one integer indicating the answer. If there are infinity common points, print -1.

Sample Input

3
0.375
0.001
0.478

Sample Output

-1
4
20

HINT

题意

给你一个正方形,然后下一个正方形是这个正方形的边上的终点连起来的,然后接着这样构造下去

然后划一条线,问你经过了多少个点

题解:


找规律题,怕爆精度,所以用的java



代码:

import java.io.*;
import java.math.*;
import java.util.*;

public class Main
{
static BigDecimal a[] = new BigDecimal[1005];
public static void main(String argv[]) throws Exception
{
Scanner cin = new Scanner(System.in);
a[0] = BigDecimal.valueOf(0);
BigDecimal x = BigDecimal.valueOf(0.5);
BigDecimal kk = BigDecimal.valueOf(0.5);
BigDecimal y;
for(int i = 1 ; i <= 1000 ; ++ i)
{
x = x.multiply(kk);
a[i] = a[i-1].add(x);
}
int Case = cin.nextInt();
while(Case != 0)
{
y = cin.nextBigDecimal();
int L = 0 , R = 500;
while(L <= R)
{
int mid = L + (R-L) / 2;
int result = a[mid].compareTo(y);
if(result == 1) R = mid - 1;
else if(result == -1) L = mid + 1;
else
{
L = mid;
break;
}
}
if(a[L].compareTo(y) == 0) System.out.println(-1);
else System.out.println(L*4);
Case--;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: